Get in touch
Back
Maintenance

Resolve software upgrade to version 8.4.0

Completed 18 Sep at 10:30pm CDT.

Resolve API
Completed

Maintenance completed

Posted 18 Sep at 10:30pm CDT.
Started

We will be deploying a new software release, 8.4.0, to Resolve production environment. Resolve frontend and APIs will remain unavailable during the window.

Posted 18 Sep at 09:30pm CDT.